Immer wieder Ärger mit WEBI (BO)

In den letzten Wochen komme ich mir fast vor wie in „Und täglich grüßt das Murmeltier“. Jeden Tag, (okay, fast jeden Tag) ein neues/anderes Problem mit BusinessObjects und WebIntelligence. Häufig kratzen die Services (WEBI Server Prozesse) ab, dann verbraucht der Tomcat zuviel Speicher, sodass gar nichts mehr geht, etc. etc. Die Probleme die wir in letzter Zeit hatten waren mannigfaltig und konnten leider nicht nachvollzogen werden, woher sie plötzlich kamen.


Den Vogel schoß aber das Problem am letzten Freitag ab: DESKI Beerichte ließen sich nicht mehr im WEBI öffnen und refreshen. Gemeinsam mit der SAP (bzw. auf deren anraten) wurde eine „Repair“ Installtion des letzten Fixpacks durchgeführt. Die Bedenken, ob dadurch nicht alle Einstellungen/Anpassungen überschrieben würden, wurde großzügig seitens der Support-Dame ignoriert und so kam es dann, dass nicht nur die Anpassungen im InfoView (eigenes Logo, etc.) überschrieben/zurück gesetzt wurden, sondern auch das „URL Forwarding“ nicht mehr funktionierte und somit unser „sprechender“ Link (der von ~500 Usern verwendet wird) nicht mehr funktionierte.

Das nächste Problem, welches danach auftrat (als man endlich wieder einen Anmeldeschirm vor sich hatte): SAP als Authentication Mode stand nicht mehr zur Verfügung. Na toll. Also musste auch das SAP Integration Toolkit neu installiert werden. Am späten Nachmittag (und das an einem Freitag!) lief dann endlich wieder alles.

Gestern stellten wir jedoch fest, dass aus irgendeinem, uns nicht bekannten Grund einige Reports invalid wurden. Fehlermeldung: FILE EXISTS BUT IS INVALID. Zum Glück hatten/haben wir ein halbwegs aktuelles Backup System 🙂 sonst wären wir wohl ziemlich angeschmiert gewesen. Was war die Lösung?

• Open WebIntelligence Rich Client on the system showing the error, but log on to the backup system.
• Import the report from the backup system and save it using the option „Remove Document Security“
• Close the report and open it again with the WebIntelligence Rich Client loged on to the productive system.
• Export the report

Of course this option only works if you have a backup system!
Alternativly you might use a stored version from your harddisk – remember to ALWAYS check the
„Remove document security“ option, if you save the document on your harddisk.

Funktioniert aber wie erwähnt nur, wenn man irgendwo ein Backup des kaputten Reports hat. Falls nicht, viel Spaß beim Neumachen 😉

Hoffentlich gehören diese Probleme mit dem Upgrade auf #BI4 endlich der Vergangenheit an!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.